pairLite
Manage Your Account
WebMail
Contact Us
 
About pairLiteHosting Plan DetailsSupportSign Up Now!
FreeBSD 7.2 Upgrade

(updated 10/7/2009)

On Wednesday, 10/14/2009, we will be updating all pairlite servers from FreeBSD 6.2-RELEASE-p1 to FreeBSD 7.2-STABLE.

An operating system upgrade is a major step, taken only after careful testing, building, and rebuilding of features in the new operating system environment. As with previous upgrades, we feel that this upgrade will bring improved stability, security, and system performance. Nearly all of the supporting software packages on our servers will receive major or minor updates, as well.

Summary of New Features

  • Perl is upgraded to version 5.8.9. Thousands of Perl modules have been updated and/or added. Perl 5.6 is no longer available. Perl version 5.10.1 is available as
    /usr/local/bin/perl5.10.1
  • Ruby is upgraded to version 1.9.1. Hundreds of Ruby gems have been updated and/or added. Ruby version 1.8.7 is still available as
    /usr/local/bin/ruby18
  • Python is upgraded to version 2.6.2. Version 2.5.2 is still available as
    /usr/local/bin/python2.5

Upgrade Notes

These notes are intended to help guide you through any changes that might be required by the upgrades to system software. If you are not sure about what to do or have any other questions, please contact us at support@pairlite.com and we will be glad to help.

  • If you are using a PHP source code decoder such as ionCube or SourceGuardian, you may need to download a new version of it. Most such source code decoders are specific to the versions of both PHP and FreeBSD (changing from 6.2 to 7.2).
Notes and caveats will be posted here as they become available. Please check back later for more information.

Return To Support
 
pairLite℠ is a proprietary service mark of pair Networks, Inc. -- © 2007-2014 pair Networks, Inc.